Tag: 点

如何让pip在代理服务器后面工作

我正在尝试使用python包pipe理器pip来安装一个包,它是从互联网上的依赖。 然而,我在我的大学代理背后,已经设置了http_proxy环境variables。 但是当我尝试安装这样的包: pip install TwitterApi 我在日志文件中得到这个错误: Getting page http://pypi.python.org/simple/TwitterApi Could not fetch URL http://pypi.python.org/simple/TwitterApi: <urlopen error [Errno 111] Connection refused> Will skip URL http://pypi.python.org/simple/TwitterApi when looking for download links for TwitterApi Getting page http://pypi.python.org/simple/ Could not fetch URL http://pypi.python.org/simple/: <urlopen error [Errno 111] Connection refused> 我甚至尝试明确地设置我的代理variables,如下所示: pip install –proxy http://user:password@proxyserver:port TwitterApi 但我仍然得到同样的错误。 如何让pip在代理服务器后面工作?

ggplot中的控制点边界厚度

当使用ggplot时,我可以将shape设置为21-25,以获得具有内部( fill )和边框( col )颜色的独立设置的形状,如下所示: df <- data.frame(id=runif(12), x=1:12, y=runif(12)) ggplot(df, aes(x=x, y=y)) + geom_point(aes(fill=id, size=id), colour="black", shape=21) 但是,我无法弄清楚如何控制形状边框的厚度,或者将它们设置为绝对的或者作为一种审美的映射。 我注意到,如果我设置了一个lwd值,它就会覆盖size美感: ggplot(df, aes(x=x, y=y)) + geom_point(aes(fill=id, size=id), colour="black", shape=21, lwd=2) 我如何控制边框的厚度?

如何控制graphviz中的节点位置(即避免边缘交叉)

我正在使用graphviz(点)来生成您可以在下面看到的graphics。 左下angular的节点(红色椭圆)会导致烦恼,因为其边缘会跨过相邻节点的几个边缘。 有没有办法限制节点放置到某个区域? 感谢您的想法 与其他边缘交叉的graphicshttp://i39.tinypic.com/e6od8z.png

我如何安装sqlite3到Python?

有人可以告诉我如何安装sqlite3包到最新版本的Python? 我使用Macbook,并在命令行上尝试: pip install sqlite 但popup一个错误。

virtualenv:指定哪些软件包使用系统范围vs本地

可能重复: 让virtualenv从您的全球网站包inheritance特定的包 有没有办法为Python创build一个virtualenv ,并指定应该从系统范围的安装中使用(inheritance) 哪些软件包 ,以及从系统范围的安装中忽略哪些软件包? 更具体地说,例如说有一个系统范围的安装: numpy scipy matplotlib 我想创build一个虚拟环境,以便: 使用numpy和scipy的系统范围的安装 忽略系统级的matplotlib ,并允许我安装/升级自己的版本 (使用pip -U matplotlib )。 这可能吗?

在Cygwin上安装新版本的Python不会安装Pip?

虽然我知道从源代码安装Pip的选项,但我试图避免这样做,所以Pip的更新将由Cygwin的包pipe理来pipe理。 我最近了解到 Python的最新版本包括Pip。 但是,即使我最近从Cygwin仓库安装了最新版本的Python,Bash也无法识别系统上有效的Pip安装。 896/4086 MB RAM 0.00 0.00 0.00 1/12 Tue, Jun 16, 2015 ( 3:53:22am CDT) [0 jobs] [ethan@firetail: +2] ~ $ python -V Python 2.7.10 892/4086 MB RAM 0.00 0.00 0.00 1/12 Tue, Jun 16, 2015 ( 3:53:27am CDT) [0 jobs] [ethan@firetail: +2] ~ $ python3 -V Python 3.4.3 883/4086 MB RAM […]

Windows上的pip安装访问被拒绝

我试图在Windows上运行pip install mitmproxy ,但是我一直在拒绝访问,即使使用Run as Administrator cmd和PowerShell选项。 WindowsError: [Error 5] Access is denied: 'c:\\users\\bruno\\appdata\\local\\temp\\easy_install-0fme6u\\cryptography-0.9.1\\.eggs\\cffi-1.1.2-py2.7-win-amd64.egg\\_cffi_backend.pyd' 我怎样才能做这个工作?

升级包,而不使用pip升级依赖关系?

我使用pip和virtualenv为我的python应用程序。 我想升级到应用程序的新版本,而不涉及依赖关系。 当我使用pip install -U ,它会尝试升级所有软件包,甚至在没有可用的新版本时卸载并重新安装相同版本的依赖软件包。 我也试过pip install -U –no-deps但是这看起来相当于一个普通的安装而不是升级。 是否有组合的标志将做我想要的?

如何在Windows上使用python 3.4?

刚刚在Windows 7上安装了python 3.4.1的全新副本。 这里说默认包含pip。 但我找不到任何pip.exe或一些pip命令。 我需要单独安装它还是存在于某个地方?

我怎样才能在这个散点图标记点?

你能帮我把标签放在下面的图表上吗? 我使用的代码是: valbanks<-scan("banks.txt", what=list(0,0,""), sep="", skip=1, comment.char="#") valbanks valj2007<-valbanks[[1]] valj2009<-valbanks[[2]] namebank<-valbanks[[3]] percent_losses<-(valj2009-valj2007)/valj2007 percent_losses abs_losses<-(valj2007-valj2009) abs_losses plot(abs_losses, percent_losses,main="Absolute Losses vs. Relative Losses(in%)",xlab="Losses (absolute, in miles of millions)",ylab="Losses relative (in % of January´2007 value",col="blue", pch = 19, cex = 1, lty = "solid", lwd = 2,text(percet_losses, abs_losses,namebank)) text(percet_losses, abs_losses,labels=namebank, cex= 0.7, offset = 10) 数据是: Value_Jan_2007 Value_Jan_2009 […]