这个iPhone 6运行iOS 10.1(14B55c),这个版本的Xcode可能不支持

我试图运行应用程序后,我更新到v8和iOS到v10,但这个错误信息popup并阻止我这样做:

这个iPhone 6运行iOS 10.1(14B55c),这个版本的Xcode可能不支持。

在这里输入图像说明 我该怎么办才能摆脱这个?

4 Solutions collect form web for “这个iPhone 6运行iOS 10.1(14B55c),这个版本的Xcode可能不支持”

要使用iOS 10.1 beta,您需要使用Xcode 8.1testing版。 Xcode 8不支持iOS 10.1 beta。

而现在,由于iOS 10.1和Xcode 8.1已经没有testing版了,所以请确保您更新到最新的两个版本。

更新 Xcode 8.1现已在app store中提供,所以您应该只更新Xcode到最新版本: https : //itunes.apple.com/us/app/xcode/id497799835? mt = 12


它看起来像iOS 10.1是今天发布,但不是Xcode 8.1。 如果您将设备升级到10.1,则需要下载Xcode 8.1 GM种子以部署到运行iOS 10.1的设备。

你可以在这里下载8.1 GM种子: https : //developer.apple.com/download/

通用种子通常是发布到应用程序商店的最终版本。

公开的Xcode 8版本不支持iOS 10.1 beta。 苹果在几天前发布了beta版本的macOS Sierra 10.12.1和iOS 10.1。 但是,watchOS,tvOS和Xcode不包括在苹果公开testing版中。

你需要Xcode 8.1 GM来使用你的10.1设备。 但是,发布一个新的iOS版本而不发布相应的Xcode版本是非常荒谬的。 东西真奇怪

  • CGRectMake,CGPointMake,CGSizeMake,CGRectZero,CGPointZero在Swift中不可用
  • Xcode正在寻找带有点的核心数据实体名称; 不编译
  • 困难转换为Swift 3
  • 奇怪的存档validation错误
  • 使用xcode 8将swift 3中的userdefaults保存字典
  • Xcode 8显示configuration文件不包含签名证书的错误
  • xcode 8推送通知function和授权文件设置
  • 如何在Swift 3中创build调度队列
  • Xcode 8中有多行注释
  • Xcode 8build议我将最小iOS部署目标从7.1更改为8.0
  • Swift 3 / Xcode 8升级 - 从工作副本错误中遗失了100个DerivedData文件