如何删除“调用需要API级别”的错误?

我在Eclipse中得到这个错误:调用需要API级别14(当前最小为8):android.app.ActionBar#setHomeButtonEnabled

这是代码:

if(android.os.Build.VERSION.SDK_INT>=14) { getActionBar().setHomeButtonEnabled(false); } 

在清单:

 <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="14" /> 

如何删除这个错误?

2 Solutions collect form web for “如何删除“调用需要API级别”的错误?”

在方法签名上方添加@TargetApi(Build.VERSION_CODES.ICE_CREAM_SANDWICH) ,其中Build.VERSION_CODES.ICE_CREAM_SANDWICH计算结果为14,冰淇淋三明治的API版本代码。

像这样:

 @TargetApi(Build.VERSION_CODES.ICE_CREAM_SANDWICH) public void yourMethod() { if (android.os.Build.VERSION.SDK_INT >= Build.VERSION_CODES.ICE_CREAM_SANDWICH) { getActionBar().setHomeButtonEnabled(false); } } 

注意:接受的答案已经过时。

Android Studio 3.0 Beta 7您不再需要@TargetApi注释。
看来,皮棉检查现在更聪明了。

所以这就够了:

 public void yourMethod() { if (android.os.Build.VERSION.SDK_INT >= Build.VERSION_CODES.ICE_CREAM_SANDWICH) { getActionBar().setHomeButtonEnabled(false); } } 
  • Java:导出到eclipse中的.jar文件
  • 无法将Eclipse中的ADT插件更新到版本23.0.0或更高版本
  • Eclipse不停止在断点处
  • 如何使用EclipsedebuggingSpring Boot应用程序?
  • 你如何设置Eclipse的iPhone开发工作(而不是Xcode)?
  • 在Eclipse中可能在IntelliJ中不可能的东西?
  • Eclipse:声明的包与预期的包不匹配
  • .classpath和.project - 检查版本控制或不?
  • 如何强制Eclipse来要求默认的工作区?
  • 在eclipse控制台中着色日志
  • 如何阻止Eclipse尝试运行XML文件?